Microsoft Edge Flagging Emerge Login Page as Unsafe

Incident Report for Emergemarket

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 10, 2026 - 16:21 UTC

Investigating

We are currently investigating an issue where some users accessing our login page with Microsoft Edge may see a browser security warning. In the meantime, we advise logging in at login.emergemarket.io using different browser.
Posted Aug 10, 2026 - 13:15 UTC
This incident affects: Web Application (Carrier TMS, Carrier RFP, Shipper TMS, Shipper RFP).